Disko Forum logo Login  |  Register  |  Lost Password
<< Start < Prev 1 2 3 Next > End >>
Re:No log file when running tutorial firststeps 01

nahsah
Posts: 24
graphgraph

No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Finally I was able to cross compile the tutorial firststeps applications.
Setting LD to g++ did the trick.

Now I wanted to run the "hello world" application on my ARM board.
I used the vesafb config file and got the following output:

[root@/usr/bin/01]#./01 --disko:config=diskorc-vesafb.xml
set configfile: diskorc-vesafb.xml

**** * *** * * ***
* * * * * * * *
* * * *** ** * *
* * * * * * * *
**** * *** * * *** V1.6-dev
----------------------------------------------------------------------
The Linux application framework for embedded devices.

Copyright (C) 2005-2007 Stefan Schwarzer, Jens Schneider,
Matthias Hardt, Guido Madaus
Copyright (C) 2007-2008 BerLinux Solutions GbR
Stefan Schwarzer & Guido Madaus
----------------------------------------------------------------------
terminate called after throwing an instance of 'MMSError*'
Aborted



I compiled disko with messages=true so there should be a log file in the directory where the application was launched.

But there is no logfile. Without a logfile it is hard to debug .

What else do I need to do to get a logfile?
Any hint would be greatly appreciated.

Thanks in advance
Nahsah
 
  The administrator has disabled public write access.
Re:No log file when running tutorial firststeps 01

Guido
Admin
Posts: 54
graphgraph

Re:No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Hi nahsah,

you have to use the option messages=yes and if desired debug=yes.

regards

Guido
 
  The administrator has disabled public write access.
Re:No log file when running tutorial firststeps 01

nahsah
Admin
Posts: 24
graphgraph

Re:No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Hi Guido

Thanks for your reply.
I used the following options to build disko:
Code:

scons prefix=/home/user/disko/build debug=true messages=true cross=true graphics=fbdev
Does it matter if messages=true or messages=yes is used? When scons starts working (building), the messages option seems to be enabled. So I don't think that's the point. My guess is that there is a access right problem. I use qemu and a nfs as rootfs to run the application. Qemu emulates the ARM based hardware. On the rootfs, there's only a single root user. What happens if this user is not allowed to create the log file on nfs? Is there any possibility to log some more detailed error information on the console? Regards nahsah
 
  The administrator has disabled public write access.
Re:No log file when running tutorial firststeps 01

Stefan
Admin
Posts: 91
graph

Re:No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Hi nahsah,

if you change the value of the logfile parameter to "" you should be able to see the log messages on stderr.

kind regards
Stefan
 
  The administrator has disabled public write access.
Re:No log file when running tutorial firststeps 01

nahsah
Admin
Posts: 24
graphgraph

Re:No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Thanks Stefan

I changed the permissions in the /usr/bin/01 directory and now the logfile works. Setting the logfile parameter to "" did also work.

So there seems to be a problem with the framebuffer.

Here's the most important part of the logging output. The whole output is attached in logfile.


Starting Disko Tutorial: firststeps/01...
18:46:28:39 1073883056 Core: initialize frame buffer [src/mmscore/mmsinit.cpp:191]
18:46:28:39 1073883056 MMSGUI: init mmsfb [src/mmsgui/mmsfbmanager.cpp:74]
18:46:28:39 1073883056 MMSGUI: get video layer [src/mmsgui/mmsfbmanager.cpp:93]
18:46:28:40 1073883056 MMSGUI: cannot initialize MMSFBLayer [src/mmsgui/fb/mmsfbbase.cpp:53]
18:46:28:40 1073883056 Core: Abort due to: cannot initialize MMSFBLayer [src/mmscore/mmsinit.cpp:299]
Error initializing disko: cannot initialize MMSFBLayer
18:46:28:41 1073883056 MMSGUI: get the grapics layer [src/mmsgui/mmswindow.cpp:229]
18:46:28:41 1073883056 MMSGUI: got flags: [src/mmsgui/mmswindow.cpp:243]
18:46:28:41 1073883056 MMSGUI: MMSW_NONE [src/mmsgui/mmswindow.cpp:251]
Segmentation fault


My hardware supporte a framebuffer device on /dev/fb0. As far as I can see in the code, disko is checking for framebuffers starting at /dev/fb0.


[root@/dev]#ls -als | grep fb0
0 crw-rw---- 1 root root 29, 0 Aug 12 18:18 fb0


Does anybody know what's wrong?

I used the original diskorc-vesafb.xml from tutorial 01 except the resolution (set to 800x480).

Any help would be greatly appreciated.

Regards
nahsah
 
  The administrator has disabled public write access.
Re:No log file when running tutorial firststeps 01

nahsah
Admin
Posts: 24
graphgraph

Re:No log file when running tutorial firststeps 01 4 Years, 11 Months ago  
Another try with the logfile:
File Attachment:
File Name: logfile-09211cd01837ef72f8cb935eaffca4a2.txt
File Size: 4252
 
  The administrator has disabled public write access.
<< Start < Prev 1 2 3 Next > End >>
Powered by FireBoard
get the latest posts directly to your desktop