Disko Forum logo Login  |  Register  |  Lost Password
<< Start < Prev 1 2 3 4 5 6 7 8 Next > End >>
Compile and install on openSUSE 11.1

René
Admin
Posts: 11
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
Hey jd,

I solved some bugs in SConstruct file and I tested it under openSUSE 11.1.

Please use scons again to build disko:
Code:

scons graphics=x11
and as root
Code:

scons install
Regards, René
 
  The administrator has disabled public write access.
Compile and install on openSUSE 11.1

jdoe
Admin
Posts: 25
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
Hi René,

i install disko in a user writable dir, is install as root necessary?



Thanks for helping

Cheers,

jd
 
  The administrator has disabled public write access.
Compile and install on openSUSE 11.1

René
Admin
Posts: 11
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
Hey jd,

QUOTE:

i install disko in a user writable dir, is install as root necessary?


no it is not .

Regards,
René
 
  The administrator has disabled public write access.
Compile and install on openSUSE 11.1

jdoe
Admin
Posts: 25
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
Hey René,

scons install tells:

Code:

KeyError: 'LIBPATH': File "/home/jd/download/morphine/disko/SConstruct", line 337: disko_pc_libs = '-L%s' % ' -L'.join(env['LIBPATH']) File "/usr/lib/python2.6/site-packages/SCons/Environment.py", line 368: return self._dict[key]
Cheers, jd
 
  The administrator has disabled public write access.
Compile and install on openSUSE 11.1

René
Admin
Posts: 11
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
Hey jd,

do you use the latest git commit?

Regards,
René
 
  The administrator has disabled public write access.
Compile and install on openSUSE 11.1

jdoe
Admin
Posts: 25
graphgraph

Re:Compile and install on openSUSE 11.1 5 Years, 6 Months ago  
René wrote:
QUOTE:

do you use the latest git commit?


yep, i did.

to be 100% sure i now removed everything, did a git clone, and invoked
Code:

scons prefix=<...> graphics=x11
which prints out:
Code:

scons: Reading SConscript files ... error: no result Checking for pkg-config... yes Checking for sigc++-2.0... yes Checking for libxml-2.0 >= 2.6... yes Checking for libpng >= 1.2... yes Checking for libcurl... yes Checking for x11... yes Checking for xv... yes Checking for xxf86vm... yes Checking for freetype2... yes Checking for sqlite3... yes Checking for openssl... yes ********************* Summary ********************* Graphic backends : x11 Database backends : sqlite3 Building mmscrypt : yes Building mmsflash : no Building mmssip : no E-Mail support : no Building tools : no log messages : no debug symbols : no profiling info : no SSE optimization : no ***************************************************
and after that:
Code:

scons prefix=<...> install
and voila it worked
no i will checkout morphine.tv again
thanks for all the help. maybe i can get the fb version working too.
Cheers,
jd
 
 
Last Edit: 2009/01/09 16:55 By Guido.
  The administrator has disabled public write access.
<< Start < Prev 1 2 3 4 5 6 7 8 Next > End >>
Powered by FireBoard
get the latest posts directly to your desktop