Disko Forum logo Login  |  Register  |  Lost Password
"-lrt" is not appropriate for embedded uclibc app

alanz
Posts: 21
graphgraph

"-lrt" is not appropriate for embedded uclibc app 6 Years, 1 Month ago  
Hi, all,

In makefile of disko, also in morphine.tv, I can find out there exist "-lrt" directive in xxx.sh file which is referenced by makefile. In my ARM uclibc env, "-lrt" will cause "Segmentation fault" when running and gdb debugging, after remove "-lrt" from the LDFLAGS, no "Segmentation fault" occur. So my point is just leave what standard runtime libs to be handled by toolchain itself, not explicitly specify in LDFLAGS.

Best regards,
Alan
 
  The administrator has disabled public write access.
"-lrt" is not appropriate for embedded uclibc app

Matthias
Posts: 64
graphgraph

Gender: Male Disko Location: Berlin, Germany Birthdate: 1979-04-25
Re:"-lrt" is not appropriate for embedded uclibc app 6 Years, 1 Month ago  
Hi alanz,

I'm currently working on using scons as our new build-system. Then we can check better for platform specific details and avoid the hassle of using autoconf. But I still need some days for testing several platforms. I'll keep you informed.

Regards,
Matthias
 
  The administrator has disabled public write access.
Powered by FireBoard
get the latest posts directly to your desktop