Disko Forum logo Login  |  Register  |  Lost Password
Re:Font show problem

danieltidus
Posts: 14
graphgraph

Font show problem 5 Years, 11 Months ago  
Hi,

I'm getting a problem when I run disko-demo sample. I can't view any font, just tv menu option works. In fact there is no fonts to show there, just pictures.

Here my diskorc.xml:

<mmsrc version="1.1.0">
<global>
<parameter name="logfile" value="./logfile" />
<parameter name="inputmap" value="default" />
<parameter name="prefix" value="./" />
<parameter name="sysconfig" value="./" />
<parameter name="data" value="./" />
<parameter name="theme" value="default" />
<parameter name="firstplugin" value="" />
<parameter name="shutdown" value="false"/>
<parameter name="shutdowncmd" value=""/>
</global>
<dbsettings type="config">
<parameter name="database" value="./configdb" />
</dbsettings>
<dbsettings type="data">
<parameter name="database" value="./datadb" />
</dbsettings>
<dfbsettings >
<parameter name="xres" value="800" />
<parameter name="yres" value="600" />
<parameter name="outputtype" value="x11" />
<parameter name="videolayerid" value="0" />
<parameter name="videolayerpixelformat" value="RGB16" />
<parameter name="videolayeroptions" value="" />
<parameter name="videolayerbuffermode" value="BACKSYSTEM" />
<parameter name="graphicslayerid" value="0" />
<parameter name="graphicslayerpixelformat" value="RGB16" />
<parameter name="graphicslayeroptions" value="" />
<parameter name="graphicslayerbuffermode" value="BACKSYSTEM" />
<parameter name="vrect.x" value="0" />
<parameter name="vrect.y" value="0" />
<parameter name="vrect.w" value="800" />
<parameter name="vrect.h" value="600" />
<parameter name="touchrect.x" value="0" />
<parameter name="touchrect.y" value="0" />
<parameter name="touchrect.w" value="800" />
<parameter name="touchrect.h" value="600" />
<parameter name="pointer" value="false" />
<parameter name="graphicswindowpixelformat" value="auto"/>
<parameter name="graphicssurfacepixelformat" value="autodetect" />
<parameter name="extendedaccel" value="true" />
<parameter name="allocmethod" value="malloc" />
</dfbsettings>
</mmsrc>
 
  The administrator has disabled public write access.
Re:Font show problem

Stefan
Posts: 91
graph

Re:Font show problem 5 Years, 11 Months ago  
Hi danieltidus,

did you compile disko with "enable-x11=y"? if yes you should use YV12 for the layer pixelformat. If not, the allocmethod parameter should be set to "directfb". In both cases, you should see more fonts

have fun
Stefan
 
  The administrator has disabled public write access.
Re:Font show problem

danieltidus
Posts: 14
graphgraph

Re:Font show problem 5 Years, 11 Months ago  
It's working ok, now!

Thanks!
 
  The administrator has disabled public write access.
Powered by FireBoard
get the latest posts directly to your desktop